Correlatore
Info Documentazione Download FAQ

Correlatore 2.1 è ora disponibile: da questa pagina possono essere scaricati gli eseguibili per Windows e Linux, lo starkit e i sorgenti. Le versioni precedenti di Correlatore non sono più supportate e il loro uso è sconsigliato. Si consiglia vivamente di leggere per intero la documentazione, poiché i criteri di segmentazioni sono leggermente cambiati e i reports creati con Correlatore 1.0 non sono compatibili con Correlatore 2.0 o 2.1. Si prega di riportare eventuali bug e/o commenti a Paolo Mairano.

Eseguibile per Microsoft Windows 2000/XP/Vista (Scarica versione 2.1)

Eseguibile per Linux (Scarica versione 2.1)

Eseguibile per MacOsX

Al momento non è disponibile un eseguibile di Correlatore per MacOsX poiché l'autore non dispone di questo sistema operativo. È comunque stato verificato che i sorgenti di Correlatore funzionano su MacOsX (si ringrazia Stephan Schmid).

Starkit multipiattaforma (Scarica versione 2.1)

Non sono disponibili versioni eseguibili per altri sistemi operativi; su queste piattaforme si possono naturalmente utilizzare i file sorgenti (v. sotto).
In alternativa, è disponibile uno Starkit di Correlatore; si tratta di un singolo file contenente i sorgenti ma di utilizzazione più semplice. Per eseguirlo è sufficiente scaricare il Tclkit relativo alla proprio sistema operativo e trascinare l'icona del Starkit di Correlatore sopra quella di Tclkit. Equi4 rende disponibili versioni di Tclkit8.5 per Solaris, FreeBSD, NetBSD e IRIX (oltre naturalmente a Windows, MacOSX e Linux) scaricabili da questo link. È necessario scaricare le versioni 8.5.2 o 8.5.1 o 8.5.0 (lo starkit di Correlatore non è compatibile con la serie 8.4).
Inoltre, va notato che lo Starkit di Correlatore non contiene Tkimg (poiché è un'estensione binaria, quindi andrebbe compilata su ogni singola piattaforma). Per questo motivo, con questo file non sarà possibile salvare i grafici in formato immagine, ma solo in Postscript (una soluzione può comunque essere quella di fare degli screesnshots e salvarli come GIF, JPEG o PNG).
Ricordo, infine, che Correlatore è direttamente supportato solo su Microsoft Windows e Linux Ubuntu.

Sorgenti (Scarica versione 2.1)

Correlatore è scritto in TCL/TK, un linguaggio interpretato multipiattaforma. Non è quindi necessaria compilazione, i sorgenti possono essere utilizzati su qualsiasi sistema opertivo senza modifiche purché sia installato TCL/TK 8.5 (È possibile utilizzare anche Tcl/Tk 8.4 ma in questo caso è necessario installare l'estensione tile; inoltre, la compatibilità con la serie 8.4 non è garantita e potrebbe essere interrotta in eventuali versioni future). ActiveState fornisce una distribuzione gratuita di TCL/TK per molte piattaforme (incluse Windows and MacOsX) chiamata ActiveTCL. Per Windows è anche disponibile WinTclTk, completamente open-source.
Su numerose distribuzioni Linux (e su molte altre versioni di Unix) TCL/TK 8.5 è già installato o presente nei repositories. Per esempio, su Ubuntu 8.04 e 8.10 è sufficiente connettersi al web e digitare in un terminale:

sudo apt-get install tcl8.5
sudo apt-get install tk8.5
sudo apt-get install libtk-img


Si noti che libtk-img è necessario solo se si desidera salvare i grafici in formati diversi da Postscript. Una volta che TCL/TK è installato, si può lanciare Correlatore da terminale: navigare fino alla cartella contenente il file correlatore.tcl e digitare

wish8.5 correlatore.tcl

Ricordo, infine, che Correlatore è direttamente supportato solo su Microsoft Windows e Linux Ubuntu.